Checking for TCL's http package

I think the http package is standard with TCL, but if you want to double-check you have it, this is how to do so on your shell:
$ tclsh
% package require http
2.5.1
% exit
$
On FreeBSD, you need to use tclsh84 not tclsh. In the example above, $ is the shell prompt and % is tclsh's.

If you get an error when you run the package require line, the eggdrop script will not work - and will also cause your bot to die when you rehash it!

b.oooom.net Home